Isotope-Nachrichten

Isotope eCommerce 2.3.0 veröffentlicht

Die erste stabile Version der 2.3er-Reihe ist endlich da!

Diese Version behebt ein paar letzte Fehler die nach der 2.3 RC2 aufgetreten sind. Insbesondere hervorzuheben ist der Aufruf von $this->generateAttribute() in Templates in Verbindung mit dem in Version 2.2 eingeführten Options Manager. Bisher hat dieser Aufruf immer nur die ID der Option ausgegeben. Das ist nun behoben und es wird korrekterweise das dazugehörige Label ausgegeben.

Wichtig: Wie bereits an diversen Stellen erwähnt verlieren damit die Versionen 2.1 und 2.2 per sofort ihren Support. Diese Versionen werden nicht mehr gepflegt. Insofern ist die Version 2.3 die aktuelle und einzige Version die eingesetzt werden sollte!

Weitere Informationen zum Release

Über Yanick Witschi

Unser Nesthäkchen, ist Kommunikator, Diplomat und Coder in Personalunion. Wenn er nicht gerade an der neusten Version von Isotope arbeitet, versorgt er Kunden von terminal42 mit massgeschneiderten Contao-Modulen.

Zurück

Kommentare

  1. Christian

    Juhu, die 2.3 stable ist da! Und sie hat mit dem geschlossenen Ticket #1450 gerade wieder mindestens einem Isotope-Enthusiasten den Tag gerettet :-)

    Danke an alle fleißigen Entwickler & Community-Mitglieder.

  2. zonky

    Hallo,

    gibt es etwas beim Umstieg von 2.2.x auf 2.3.x etwas spezielles zu beachten?

    Gruss & Dank

    • Hi,

      Nein, im Prinzip nicht. Wir halten uns an SemVer. Insofern dürfen keine inkompatiblen Changes drin sein. Allerdings gibt es durch die neuen Features auch Anpassungen an Templates, welche nicht SemVer unterliegen. Gerade bei den Rechnungen, dem einschränkenden Filter oder der Preis-Anzeige. Daher gilt, wie immer Backup machen, die geänderten Templates mit den Originaldateien vergleichen (geht ja ab Contao 3.5 ganz leicht) und testen :-)

      Viel Spass!

  3. Hallo,

    wenn ich über Composer isotope/isotope-core aufrufe, ist die Version 2.3.0 durchgestrichen! "Diese Paket-Version ist mit dieser Contao-Version nicht kompatibel!"
    Meine Contao Version ist aber 3.5.2
    Php-Version ist 5.4.16

    Wenn man hartnäckig bleibt und weiter macht, installiert der Composer dann doch!
    Sehr eigenartig!

    VG Steffen Winde

    • Das habe ich bei der RC auch schon gesehen. Für Fehlermeldungen aber besser GitHub benuztzen: https://github.com/isotope/core/issues/1519

Einen Kommentar schreiben

Folgender BBCode kann beim Kommentieren verwendet werden:
  • [b]fett[/b]
  • [i]kursiv[/i]
  • [u]unterstrichen[/u]
  • [img]http://isotopeecommerce.org/files/isotope.png[/img]
  • [code]<?php echo "Hallo Welt"; ?>[/code]
  • [quote]Text als Zitat darstellen[/quote]
  • [quote=Isotope]Text als Zitat eines Autors darstellen[/quote]
  • [url]http://isotopeecommerce.org/[/url]
  • [url=http://isotopeecommerce.org/]Isotope eCommerce[/url]
  • [email]mail@example.com[/email]
  • [email=mail@example.com]E-Mail[/email]